As of the Lightpath 4.0 Release, our product requires the .NET 4.0 Framework from Microsoft. Please visit the Microsoft Download Center to download .NET 4 if needed. (Free)

Existing customers please contact our Support Team: support@lightpathdigital.com


Downloads

Latest Version: 4.0, October, 2012 - Download (94 MB Zip)

Notes for Display Software 4.0

  • After you install the Editor or Display applications, please run the installs that will be in the installations DirectX directory (IE: C:\Lightpath\DirectX ).
  • The Shockwave installer in the DirectX Folder has an option to install software from Norton. This software is not required and Lightpath recommends that you do not install it.